Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently July 18 2019, 10:16 PM



Reply to topic  [ 16 posts ]  Go to page 1, 2  Next
 Eunos 30X 1995 Running Rough under 2000 Revs 
Author Message
Junior Member

Joined: February 23 2009, 10:18 PM
Posts: 11
Reply with quote
Post Eunos 30X 1995 Running Rough under 2000 Revs
Hey Guys,

Got a bit of a pickler here. I have a 1995 Eunos 30X that's been running rough for a while now. After 2000 - 2500 revs it runs beautifully, but before that it's very jerky and has almost no torque so I have to rev the crap out of it before I can disengage the clutch to get it to move. I've taken it in to a mechanic who checked the intake accordian and also the Airflow Sensor and 500 bucks later was told that for some reason all the spark leads needed replacing. That seemed to fix the problem for a few weeks, but now its back to where it was again. Given that I don't want to waste another 500 bucks, I was hoping someone might have a few ideas.

I've also recently replaced the distributor myself, so was wondering if I've somehow screwed something up in the process.

Any ideas?


February 23 2009, 10:24 PM
Profile
Forum Moderator
User avatar

Joined: August 10 2005, 10:08 PM
Posts: 6128
Location: Hillsboro, OR
Reply with quote
Post Re: Eunos 30X 1995 Running Rough under 2000 Revs
when you replaced the distributor, did you ensure you put it back in the exact same spot? if not you might have advanced or retarded the timing by accident.

_________________
My Feedback
92 mx-3 gs klze 'race car' IP 15.05 @ 92.5mph
92 mx-3 gs klze 'daily driver' IP 14.55 @ 95.7mph
http://www.cardomain.com/id/Mooneggs
Image


March 24 2009, 3:22 PM
Profile WWW
Junior Member

Joined: February 23 2009, 10:18 PM
Posts: 11
Reply with quote
Post Re: Eunos 30X 1995 Running Rough under 2000 Revs
Hmm, not a bad idea. I suppose I can try moving it back and forward a bit and see if things improve. It was running fine for a while after I changed it though, but maybe its slipped out of position.


March 31 2009, 11:40 PM
Profile
Senior Member

Joined: August 25 2004, 2:01 AM
Posts: 5554
Location: Edmonton, Alberta, Canada
Reply with quote
Post Re: Eunos 30X 1995 Running Rough under 2000 Revs
The Distributor can only be inserted in one position. I believe if you had inadvertently rotated the housing the ECU would compensate to correct the timing unless the Data Link Ten and GRD were jumpered.

My sense is that this is not a timing issue. I would suggest the following:

Clean up/replace engine grounds
Set Timing (to be certain) with the data link jumpered as per the manual
Set TPS
Set idle
Change your Fuel Filter

That's about $12 worth of easy maintenance. From there you have a more certain starting position.

_________________
94' RS/GS/MS/CF Monster Turbo...coming soon.
93' GS SE, the Black Beast, the former love of my life...soon to be gutted and crushed.
94' GS, black on black, now in several small pieces...and one large crushed piece.
2007 Mazda3 GT Sport --- super fun
2004 Honda RC51 --- Lost forever to some theavin' bastard
My Worklog
My feedback thread
Never attribute to malice that which can be adequately explained by stupidity.


April 01 2009, 2:29 PM
Profile
Junior Member

Joined: February 23 2009, 10:18 PM
Posts: 11
Reply with quote
Post Re: Eunos 30X 1995 Running Rough under 2000 Revs
Bought a timing light and checked the timing, was okay. However found out that when I put my foot down hard, the spark stops. If I rev it up slowly, then the spark on cylinder 1,3,5 is okay at hight revs, but is gone from cylinder 2,4,6. I'm thinking its the distributor again. Might be worth doing the HEI mod, what do you reckon?


May 20 2009, 3:05 AM
Profile
Senior Member

Joined: August 25 2004, 2:01 AM
Posts: 5554
Location: Edmonton, Alberta, Canada
Reply with quote
Post Re: Eunos 30X 1995 Running Rough under 2000 Revs
well there's no obvious explanation as to why the rear cylinders get spark and the front ones don't. I would try another distributor and see if it changes. That's a wierd one.

_________________
94' RS/GS/MS/CF Monster Turbo...coming soon.
93' GS SE, the Black Beast, the former love of my life...soon to be gutted and crushed.
94' GS, black on black, now in several small pieces...and one large crushed piece.
2007 Mazda3 GT Sport --- super fun
2004 Honda RC51 --- Lost forever to some theavin' bastard
My Worklog
My feedback thread
Never attribute to malice that which can be adequately explained by stupidity.


May 20 2009, 1:41 PM
Profile
Junior Member

Joined: February 23 2009, 10:18 PM
Posts: 11
Reply with quote
Post Re: Eunos 30X 1995 Running Rough under 2000 Revs
Okay so did the HEI mod (w/o coil) and it made it a bit better, but not much. Then I tried doing the external coil mod, so wired up the external coil and modded the dizzy. Ended up pulling the dizzy to pieces following the instructions on clubprotege looking for the tacho strap, but couldn't find it. I think my dizzy is different (The tower is on the coil, not on the cap). Put the dizzy back together and tried the car, but couldn't get it to start.

So checked spark on each cylinder and it was there and nice and bright, but seemed to be not often enough, like maybe only every 2nd or every 3rd spark was making it. I don't know how fast the starter turns the crank, but it seemed a bit slow. I thought I'd done the cap mod wrong and it was arcing, so I tried to make it better and ended up screwing it up more and ended up with no spark at all. :-(

Figuring that the dizzy cap was now shot, I ordered another one and got a new rotor too. Thought I'd return the configuration to stock and just get it limping again before I messed with it any more, so plugged the wires back into the dizzy, removing the HEI and external coil and turned the key. There was a crack of ignition and big cloud of black smoke rose out of the engine and then nothing. Figured I'd blown the ignition module somehow, checked my wiring, but was all okay and checked for spark and it was there and again nice and bright, but again seemed to be not often enough. However there was no more ignition after the first one.

Turns out the fuel ignition fuse had blown. Replaced it with the blower fuse because I didn't have any others on hand. Turned the key again and blew that fuse too. Arrggh! :crying:

So my questions are:
- What does the blown fuel injection fuse mean, have I broken something?
- How often should my cylinders be sparking (ie what RPM does the starter motor turn the crankshaft)
- What could cause the spark to be less often that it should be (Did I screw up the distributor reassembly?)
- Should I give up and buy a new car?


May 26 2009, 11:21 AM
Profile
Senior Member

Joined: August 25 2004, 2:01 AM
Posts: 5554
Location: Edmonton, Alberta, Canada
Reply with quote
Post Re: Eunos 30X 1995 Running Rough under 2000 Revs
I would say with a fairly high degree of certainly that you have a short in the fuel injection harness. That fuse blows because power is going from B+ to ground without passing through the load of the injectors. Because there is no load and no voltage drop too much current is getting to ground and blowing the fuse.

It is theoretically possible for the frequency of the sparks to be reduced by half if the igniter is defective. But it seems really unlikely to me. If you had a digital tach at your disposal you could determine how fast the starter is turning the engine and calculate how often a spark should be seen. Even without ignition, the tach on the dash would still register the engine speed while cranking. My best guess says that it only turns at about 100-150rpm and you should see something like a couple of sparks per second. It would be easily discernable with the naked eye.

Find that short first and then get a known good distributor on the engine.

_________________
94' RS/GS/MS/CF Monster Turbo...coming soon.
93' GS SE, the Black Beast, the former love of my life...soon to be gutted and crushed.
94' GS, black on black, now in several small pieces...and one large crushed piece.
2007 Mazda3 GT Sport --- super fun
2004 Honda RC51 --- Lost forever to some theavin' bastard
My Worklog
My feedback thread
Never attribute to malice that which can be adequately explained by stupidity.


May 26 2009, 11:54 AM
Profile
Junior Member

Joined: February 23 2009, 10:18 PM
Posts: 11
Reply with quote
Post Re: Eunos 30X 1995 Running Rough under 2000 Revs
Okay, so I replaced the two fuses and so far nothings blown again, so not sure what was happening last night, but it's stopped. Maybe some of the wires around the dizzy were shorting and how they're not. Tried the car again, it seems like it wants to start (there's a rumbling from the engine, like somethings igniting, but it just won't turn over).

Got the scope out and checked the ignition signal, it's pulsing about 10 times a second. Checked the Crank and Cam sensor signals from the disty and they're pulsing at about 10 and 1 times a second. Also had a look at how fast the rotor is spinning and it's at about 10 times a second too, so that all seems to make sense. Guess the starter motor doesn't turn the engine that fast.

Now a few things I noticed, the tachometer in the dash doesn't move when the starter is turning the engine. Not sure if this is normal or not, could be I've blown the tacho input to the ECU. The other thing is that if I try and flash the codes (jumper between TEN and GND) then the CEL doesn't flash. In fact it doesn't light at all. Should I be concerned? Have I blown the ECU??

The only other thing I can think of is I've somehow reassembled the disty wrong and the sensor signals are pulsing at the wrong times, causing the ignition to be firing at the wrong point. I'm not sure how this is possible, but I'll check tomorrow.

Any other suggestions would be appreciated!


May 27 2009, 7:03 AM
Profile
Junior Member

Joined: February 23 2009, 10:18 PM
Posts: 11
Reply with quote
Post Re: Eunos 30X 1995 Running Rough under 2000 Revs
Okay, looks like I have the Jap model that doesn't have a CEL, which explains why it wasn't lighting up. I put a LED between FEN and B+ and in Diag Mode (TEN and GND) it lights for 2 seconds and then turns off. Then I wait for codes to flash, nothing, still at least my PCM is okay.

So there's no codes, but it won't start. Help!


May 27 2009, 9:54 PM
Profile
Senior Member

Joined: August 25 2004, 2:01 AM
Posts: 5554
Location: Edmonton, Alberta, Canada
Reply with quote
Post Re: Eunos 30X 1995 Running Rough under 2000 Revs
You need a known good distributor.

_________________
94' RS/GS/MS/CF Monster Turbo...coming soon.
93' GS SE, the Black Beast, the former love of my life...soon to be gutted and crushed.
94' GS, black on black, now in several small pieces...and one large crushed piece.
2007 Mazda3 GT Sport --- super fun
2004 Honda RC51 --- Lost forever to some theavin' bastard
My Worklog
My feedback thread
Never attribute to malice that which can be adequately explained by stupidity.


May 27 2009, 10:51 PM
Profile
Junior Member

Joined: February 23 2009, 10:18 PM
Posts: 11
Reply with quote
Post Re: Eunos 30X 1995 Running Rough under 2000 Revs
Well I'm feeling pretty stupid right now. The reason why the car wasn't starting is because I had the rotor on the wrong orientation. I got a new rotor with my new disty cap and it wasn't keyed like the old one so It could go on three different ways and I had it on the wrong one. :oops:

After putting the rotor back on the right way, I got the car back in its running crap state and then redid the HEI mod + coil mod. It's now running like a new car! :D

I recommend the HEI mod to any people having rough running as a excellent way to start, just make sure you know what you're doing!


May 31 2009, 8:29 PM
Profile
Regular Member

Joined: April 09 2007, 8:11 AM
Posts: 912
Reply with quote
Post Re: Eunos 30X 1995 Running Rough under 2000 Revs
Lol nice work, good thing you figured it out!

_________________
1995 Eunos 30x KLZE
Worklog


June 10 2009, 4:38 AM
Profile
Junior Member

Joined: July 27 2009, 1:05 AM
Posts: 6
Reply with quote
Post Re: Eunos 30X 1995 Running Rough under 2000 Revs
This is exactly what my car is doing!!!!!... this might sound dumb to you guys but what do i have to do to the HEI mod + coil mod.???


February 27 2010, 10:25 AM
Profile
Junior Member

Joined: April 02 2010, 1:01 AM
Posts: 13
Location: Coffs Harbour, NSW, Australia
Reply with quote
Post Re: Eunos 30X 1995 Running Rough under 2000 Revs
I have the same issue, basically under 2000RPM its crap, feels like its missing and not getting the right fuel air mix. i was gunna run a bottle of injector cleaner through her before i attemped the HEI mod + coil mod. Im a lil touchy on doing this as i just bought the car and dont wanna stuff anything up. but over 2000RPM it runs like a dream.

_________________
1991 Subaru L Series Wagon (Sold)
1989 Nissan Pulsar N13 (Crashed)
1989 Honda Prelude 3rd Gen (Crashed/Flooded)
1991 Daihatsu Charade (Timing belt snapped; Engine destroyed)
1995 Mazda Mx-3 1.8L V6 K8 (Current, Sports Exhaust and K&N Intake).
:) All I want is a good looking car, THAT CAN EAT THOSE COMMODORES! :)


April 10 2010, 4:40 AM
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 16 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.