Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently August 20 2019, 11:10 PM



Reply to topic  [ 1 post ] 
 Lack of power? Tps/boost sensor 
Author Message
Regular Member
User avatar

Joined: April 16 2009, 2:05 AM
Posts: 251
Location: Lowell, MA
Reply with quote
Post Lack of power? Tps/boost sensor
So I have a 93 mx3 rs ,l1.6
I have no check engine light to make a long story short

I have replaced the fuel pump fuel filter fuel injectors fuel pressure regulator

I have replaced the distributor cap and rotor plugs and wires I have an MSD blaster ignition coil

And as for the air I have the simple mod adapter with cyclone ahead I am going to upgrade later but I need to get the car running back to normal first

Other than the air fuel and spark the only other thing I can think of is its a sensor

This has been a project car over the years that's why I have changed everything and I just recently did the head gasket again with no issues so I want to rule that out being the cylinder pressure

I need to get a better understanding if I am missing something

_________________
03 Dodge Neon (rental i had for a month but i ran that into the ground for sure)
95 Chrysler Concorde (Junked my first car [still ran])
90 Nissan Stanza (Junked [wouldnt start one day])
89 Saab 9000 CD (sedan/turbo very fun but electrical problems[city towed away for no plates on private property])
94 Toyota Camry (mothers old car fixed it then broke it[dont ask] Junked)
93 MX-3 RS (My project for 3 years so far)
97 Honda Civshit (Beater/Stereotypical POS Honda im fixing)


December 21 2014, 7:47 PM
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.