MX-3.com
http://mx-3.com/phpBB3/

Throttle is a bit harsh.. need help ! klze.
http://mx-3.com/phpBB3/viewtopic.php?f=15&t=82056
Page 1 of 1

Author:  metallinen [ May 23 2016, 5:20 PM ]
Post subject:  Throttle is a bit harsh.. need help ! klze.

Hey guys, i have a freshly swapped klze, still on the break-in.
Everything is fine, except something i've never seen, when i press the throttle gently it wont move smoothly.
Let's say.. i can't use 5-10% throttle, i have to press a bit harder to go down.. it makes going from a stop smoothly impossible.

I've checked the cable and everything.. lubed the pedal and the TB.. one weird thing, when the engine is not running the pedal seems to be fine.

Specs : mx3 gs 1992, kl-ze curve neck (kl68 TB),KL31 ecu, k8 transmission, bully stage 2 clutch

Author:  MX_Sid [ May 24 2016, 1:49 AM ]
Post subject:  Re: Throttle is a bit harsh.. need help ! klze.

Stupid question, did you lubricate the cable between the pedal and the throttle body? I have heard about those sticking....?

Author:  metallinen [ May 24 2016, 12:10 PM ]
Post subject:  Re: Throttle is a bit harsh.. need help ! klze.

Yes, and it is the same cable i had with my k8, which was fine as far as i know.. i should make a video of the problem, it is hard to explain for me because usually i speak french

Author:  MX_Sid [ May 25 2016, 3:19 AM ]
Post subject:  Re: Throttle is a bit harsh.. need help ! klze.

Does it feel like the pedal is Physically sticking, or like there is a lag in the throttle response?

Author:  metallinen [ May 25 2016, 12:35 PM ]
Post subject:  Re: Throttle is a bit harsh.. need help ! klze.

Really like sticking in the 5-15% throttle.. after this, it goes smooth

Author:  RX8SE3P [ May 27 2016, 5:41 AM ]
Post subject:  Re: Throttle is a bit harsh.. need help ! klze.

You might need to play with the throttle cable's mounting bracket near the throttle body. I had a problem when I went to curve neck manifold on my ZE where the cable was a bit loose. It idled too high and sort of drove itself, with bad throttle response too because of the looseness.

I literally angled the mounting bracket a little to provide more tension and remove all looseness. Never had an issue after that.

Author:  metallinen [ June 01 2016, 11:01 AM ]
Post subject:  Re: Throttle is a bit harsh.. need help ! klze.

Strangely, i had some loose, but did not cause driveability problems, and had excellent throttle response..
Now i fixed the loose, still the same issue -.-

Author:  MX_Sid [ June 28 2016, 5:06 AM ]
Post subject:  Re: Throttle is a bit harsh.. need help ! klze.

You got me stumped... If the pedal acts normal when the engine is shut down, but sticky when the engine is running, maybe the engine pressure REALLY wants to GO. What happens in this 5-10%? Or, is it unattainable?

Can you compensate for the gap with the clutch? Kind ov cool if your catch point changed, based on set up.. Like your MX is evolving.

When you did the swap, did you do anything with the clutch?

Author:  [LVPA]93GsSe [ July 17 2016, 7:15 PM ]
Post subject:  Re: Throttle is a bit harsh.. need help ! klze.

Did you try cleaning and lubing the throttle spring?

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/