Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently December 11 2019, 8:38 PM



Reply to topic  [ 7 posts ] 
 OK everyone, my 1.8 runs poor + fuel injector cleaning? 
Author Message
Junior Member
User avatar

Joined: April 13 2010, 10:47 PM
Posts: 7
Location: Kelowna, BC
Reply with quote
 OK everyone, my 1.8 runs poor + fuel injector cleaning?
What happened?

Tore the front end apart, replaced a few things:

NEW
*Wires (double checked firing order, good)
*Plugs
*Accessory Belts (broke lower tensioner, belt slightly loose)
*Disty replaced 20K ago, Altenator & Timing Belt too
*Cleaned TB
*Airbox is mint

~Steam cleaned engine (could be cause of problem)

~Added GUNK engine stop smoke to Mobil 1 10W-30
(likely cause of problem)

Started her up, ran great. For a bit. The disty started to cook a little hole in the cover...(?)

Two days later, here I am.

Runs poor across powerband, consumes twice the fuel, backfires the odd time, idles at 400-600rpm when warm.

>changed to a thinner oil, 5W-20. Runs a bit better

Car throws codes 17 & 24 (your favourites).

I'm close to positive I've got no vacuum leaks. I squeezed the hoses and they felt good + no visual deterioration.

-I'm assuming that the gunk crud gummed up my fuel injectors!
-Did my steam cleaning mess with the ECU?
-Any other suggestions?

The car ran like a gem before. I see no reason for the car to have jumped timing; it runs like crap all over.

If the conclusion is sticky fuel injectors (a 1st for me), should I:
-shove some reputable Inj. Cleaner in the tank
-pull the injectors all together & clean with something
-pull fuel line and dump in some vicious nitro of sorts
-admit defeat and get some injectors from scrapyard

ALL suggestions are appreciated as are refrences to other threads I didn't find. I appreciate it,
- Pat

_________________
L.St.Pierre & V.N. are my heroes


April 26 2011, 8:40 PM
Profile
Supporting Member
User avatar

Joined: June 18 2007, 10:51 AM
Posts: 7055
Location: Trenton ON.
Reply with quote
Post Re: OK everyone, my 1.8 runs poor + fuel injector cleaning?
Ok
A. Replace that fookin disty cap and rotor with a good one.
B. Check for water in the spark plug wells
C. Stop being a noob.
Thank you. :D

OH,,,D. Sea Foam your engine

_________________
2004 Subaru WRX Silver, stage 2, minty interior.
2002 Subaru WRX Blue, SOLD (best E test numbers I've ever seen)
94 MX-6. Sold
92 GS KLZE 5 Speed
96 GS 5 speed, KLZE, Sold
95 GS Minty Shape Sold
92 GS Sold
92 GS Parts Car scrapped.
Feedback viewtopic.php?f=37&t=66348" onclick="window.open(this.href);return false;
7477th member.

I know you believe that you understand what you think I said but I'm sure you realize that what you heard is not what I meant.


April 26 2011, 9:27 PM
Profile
Regular Member

Joined: November 02 2009, 4:03 AM
Posts: 1751
Location: Vancouver, BC
Reply with quote
Post Re: OK everyone, my 1.8 runs poor + fuel injector cleaning?
Quote:
C. Stop being a noob.


Awesome!


April 26 2011, 9:39 PM
Profile
Junior Member
User avatar

Joined: April 13 2010, 10:47 PM
Posts: 7
Location: Kelowna, BC
Reply with quote
Post Re: OK everyone, my 1.8 runs poor + fuel injector cleaning?
You bet, pulled the plugs back when, nothin' to see there.

Update if yer wrong.

_________________
L.St.Pierre & V.N. are my heroes


April 27 2011, 2:26 AM
Profile
Regular Member

Joined: March 30 2006, 9:55 PM
Posts: 709
Location: Calgary, Alberta
Reply with quote
Post Re: OK everyone, my 1.8 runs poor + fuel injector cleaning?
WD-40
Water Displacement - 40 your electrical connectors you steam cleaned

and then as suggested seafoam the snot out of the engine.

_________________
Image
1994 MX-3 RS
Worklog: viewtopic.php?f=46&t=62251
B6 goodies for sale:
viewtopic.php?f=2&t=66333
2nd BP engine: http://www.clubprotege.com/forum/showthread.php?t=46695


April 27 2011, 2:47 AM
Profile
Junior Member
User avatar

Joined: April 13 2010, 10:47 PM
Posts: 7
Location: Kelowna, BC
Reply with quote
Post Re: OK everyone, my 1.8 runs poor + fuel injector cleaning?
Thanks for all the help.

Judging from the hole in my dist. cap I guess my pressure washing forced water where it shouldn't and caused some arcing to happen (duh?). Good call

The rotor was worn down on the underside from rubbing. I guess the part didin't fit right or else my coil is expanding (haha...). The new rotor (Beck & Arnley) is identical to the one i'm replacing. Oh well

Sea foam...great invention. I found it after staring for 5-7 minutes at the wall at Cambodian Tire. Told my parts store guy about it + a corvette guy in the shop said his club is all about it. Kudos to you

>> Used 3/4 can, the car ran poor for 2 days & sounded like a WRX. Then I parked it, went to work, came out to go home and it ran like brand new.

Never WD-40'd my electronics but I won't forget that advice. Thanks to all, happy tuning.

-Pattytricks

_________________
L.St.Pierre & V.N. are my heroes


May 10 2011, 2:02 PM
Profile
Junior Member
User avatar

Joined: April 13 2010, 10:47 PM
Posts: 7
Location: Kelowna, BC
Reply with quote
Post Re: OK everyone, my 1.8 runs poor + fuel injector cleaning?
I smile when I read this topic. What a class act

_________________
L.St.Pierre & V.N. are my heroes


February 22 2016, 4:33 AM
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.