Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently November 12 2019, 12:23 PM



Reply to topic  [ 1 post ] 
 Constant fan on with KL31 ECU fixed (94-95) 
Author Message
Supporting Member
User avatar

Joined: June 18 2007, 10:51 AM
Posts: 7055
Location: Trenton ON.
Reply with quote
Post Constant fan on with KL31 ECU fixed (94-95)
I found this on Mazda 626.net posted by a member called 'sizzzla'.

Hi guyz/gurlz, I have finally figured out the fix for the "constant fan" problem we've been having with the KL31 ecu. As you know the KL31 ecu came with the mtx ZE and the KL36 ecu with the atx. My ZE has two temp. sensors, but my usdm harness only has one plug. Well, luckily my ZE came with the section of the harness that has both plugs for the sensors, and for some time I tried figuring out where on the KL31 ecu I needed to hook up this second sensor to get things working right. Well, I came across a post which gave the location and function of every pin on the 94 usdm ecu, and with the use of the Haynes manual I found out the 93 KL03 also came with two temp. sensors much like the ZE. So, I decided to hook up the second temp. sensor on the ZE like that of the 93 KL03. Now to do this I had to add a pin connector to the middle plug of the ecu. ( I hope I havn't lost you all) You see, the ecu has three plugs, the center plug is the one in concern. If you take a good look at it you will notice there is an empty spot on the top row. It's the fith spot from the left. Well, I got a pin conector from an old harness, inserted it into the spot, ran a separate wire from it and connected it to the pink/blue wire of the second temp. sensor. The black/blue wire of the sensor is a ground, so I spliced it with the black/blue wire of the first sensor that was already in use, then reseted the ecu and "voila" no more "constant fans"
I am pretty sure someone knew that and has done it, but I searched high and low in here for a year and found no write up on it..maybe I searched wrong... Well guys, I couldn't be more ecstatic and decided to share the news with you all. BTW, if your ZE didn't come with the plug for the second sensor, get it off a 93 KL03.

Kinda late in the game but it may help someone here.

_________________
2004 Subaru WRX Silver, stage 2, minty interior.
2002 Subaru WRX Blue, SOLD (best E test numbers I've ever seen)
94 MX-6. Sold
92 GS KLZE 5 Speed
96 GS 5 speed, KLZE, Sold
95 GS Minty Shape Sold
92 GS Sold
92 GS Parts Car scrapped.
Feedback viewtopic.php?f=37&t=66348" onclick="window.open(this.href);return false;
7477th member.

I know you believe that you understand what you think I said but I'm sure you realize that what you heard is not what I meant.


August 05 2014, 5:15 PM
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.